ИНСТРУКЦИЯ

Пошаговая инструкция по установке Viber в Linux Debian 9 и дистрибутивах на основе Debian и Ubuntu.

UPD - 22.12.2018. Обновлены ссылки.

Проблема заключается в том, что для успешной установки Viber требуется отсутствующий в репозитории Debian 9 Stretch пакет libssl1.0.0. Для решения этой небольшой проблемы стоит пакет скачать и установить.

  1. С сайта Debian скачиваем последнюю версию пакета libssl1.0.0 для нужной архитектуры. На момент написания заметки последняя доступная версия - 1.0.0_1.0.1t-1+deb8u9. Прямые ссылки: amd64, i386.

    Если пакеты по ссылке недоступны, то, скорее всего, они опять обновились и нужно просто пройти сюда и найти подходящий пакет вида libssl1.0.0_1.0.1t-1+deb8(версия)_(архитектура).deb. А еще можно сделать доброе дело и написать об этом в комментариях, чтобы я обновил ссылки.

  2. Устанавливаем только что скачанный пакетик:
    $ sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u9_amd64.deb

    или

    $ sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u9_i386.deb
  3. Скачиваем и устанавливаем Viber
    $ wget http://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
    $ sudo dpkg -i viber.deb

    Не обращаем внимания на сообщения об ошибках.

    Unpacking viber (7.0.0.1035) ...
    dpkg: dependency problems prevent configuration of viber:
    viber depends on gstreamer1.0-plugins-ugly; however:
    Package gstreamer1.0-plugins-ugly is not installed.
    viber depends on gstreamer1.0-pulseaudio; however:
    Package gstreamer1.0-pulseaudio is not installed.
    viber depends on gstreamer1.0-libav; however:
    Package gstreamer1.0-libav is not installed.

    dpkg: error processing package viber (--install):
    dependency problems - leaving unconfigured
    Processing triggers for desktop-file-utils (0.23-1) ...
    Processing triggers for mime-support (3.60) ...
    Processing triggers for hicolor-icon-theme (0.15-1) ...
    Errors were encountered while processing:
    viber

  4. Устанавливаем необходимые зависимости (скорее всего, это будет только gstreamer1.0-pulseaudio):

    $ sudo apt-get install -f
  5. Проверяем и радуемся результату!
Blog Comments powered by Disqus.